Thursday, November 12, 2009

How to fix Windows XP Service Pack 3 - Extraction Error - File is Corrupt

Machine AMD3800 - MSI Motherboard

I decided I want two OS on my old system. It appears that the older drivers for the RAID system work better in XP, Win2000, etc and there isn't any Win7 updates.

I tried installing XP with SP3 (not final) and then do Windows Updates. It was a disaster.

Later  I decided to install XP with SP2 that went smooth. But SP3 was another headache.

I ran into the above error while trying to install SP3 from ISO file using SlySofts virtualDisk.

The solution is to something other than SlySoft Virtual Disk like MagicDisk or even burn the disk to a CD.

Also as another precaution to run the update in Safe Mode according to what I read. It couldn't hurt to avoid more potential after SP3 errors.

Service Pack 3 surely is a difficult one to install much like installing Service Packs in NT4.

I usually re-install the OS with the latest SP already installed but the one I got last time with SP3 wasn't the final one.

So far SP3 is holding out ok ... later I will do some windows updates

If something breaks major - then I will try again with XP with SP3 Final.

I notice that Win7 USB sucks on the old system - XP is better at hot swapping USB detection.

Monday, November 2, 2009

How to fix Error Code 5 during Windows 7 Installation on AMD Computer

I was excited that Windows 7 installed perfectly on my two laptops from 2006 and 2007. So I decided to see if it would install on my older desktop machines from 2005. Well, it turns out that one out of the two didn't work. So I tried and tried and research and tried for almost two weeks.
Computer: AMD3800, MSI Mother Board, AGP Video Card, DDR 400 Memory
Issues - Encountered or read about
A) "Code 5 Error" - The Windows 7 DVD won't boot.
B) "Bootable Windows 7 USB" - It turns out my USB only recognizes FAT32 not NTFS during boot.
C) "Stuck at nn%" during install = or = "Stuck at completing installation"
D) Windows 7 Upgrade - Installing via an upgrade route from VISTA Regular to Windows 7. Encountered issues installing SP1. It was appalling to see how hard it was to install a service pack.
E) Hyper Transport - A memory issue for Windows 7 Setup
F) Video Card - After retesting the procedure I found out I do not have a video card issue. But for other people it was a problem and they had to substitute their card.
So this is the procedure that worked for me after two weeks.
1 - Re-Build Windows 7 Install Disk

2 - Build Windows 7 USB
Updated 11/14/2009 - MS Remove the above tool due to violations of GPL lic after discovery.

Here is another link - I have tried earlier in my research to create a bootable USB.
You will have to manually copy the Win7 DVD on to the USB.

I haven't tried it for this substitute method. But I think it will still work since I recall that the USB still gets formated in NT format in the MS Tool.

3 - Re-Label USB to same as DVD Label (ie: "GRMCULFREO EN DVD")

4 - BIOS
4a - Cell Menu - Reset to Optimized Defaults
4b - Set All Options to your preferences except Cell Menu. ( ie: Disable Serial Port,Parallel Port, etc)
4c - Make sure memory speed is correct.
4c - Change Boot Order to DVD, Hard Drive, None
5 - Insert USB and DVD
6 - Boot on DVD
5 - Remove DVD after Win 7 Dvd boots up
6 - Click on Next and perform the install
7 - After Win7 loads up files to the hard drive it will try to do the reboot but leaves you at blue background screen
8 - Remove USB, DVD
9 - Reboot
10 - Press F8 - Enable Low resolution 640x480
11 - Win 7 Starting Screen -> installation completes
12 - Reboots
13 - Press F8 - Enable Low resolution 640x480
14 - Enter your UserID, etc
15 - Installation done.
16 - Restart
17 - Check out Win 7 - if happy with it then you're DONE.
If you have issues regarding transfer speed and memory. You will have to tweak your BIOS regarding the hyper transport and memory speed.
18 - BIOS - Recheck Cell Menu Options to get efficiency in Win 7. Watch out if your setting aren't correct. Win7 may not boot to the desktop which means you will have to figure out the Cell Menu settings. It turned out for me the memory speed to be on Manual - not automatic.
19 - Recheck Windows 7
20 - If still an issue go back to step 18 Otherwise your done.
I say it took a long time to find out out the right procedure to get Windows 7 installed correctly but I'm glad it does indeed run.